WordPress 3.4.2, actualización de mantenimiento y seguridad disponible.

Desde el blog de desarrollo de WordPress, nos llega el aviso del lanzamiento de una nueva versión. Esta entrega del CMS (3.4.2) está catalogada como de mantenimiento / seguridad y viene a solventar 18 bugsde las versiones 3.4 y 3.4.1, incluyendo:

  • Corrige algunos problemas en el área de administración donde algunos navegadores antiguos (IE7, en particular) puede ralentizar, LAG o congelación.
  • Soluciona un problema por el que un tema no puede obtener una vista previa correctamente, o su captura de pantalla no puede mostrar.
  • Corrige el uso de URL trackback múltiple en un post.
  • Evita las imágenes de tamaño inadecuado se carguen como encabezados de la personalización.
  • Asegura mensajes de error apropiados se puede demostrar que se instala PHP4. (WordPress requiere PHP 5.2.4 o posterior.)
  • Corrige el manejo de proveedores oEmbed que sólo devuelven respuestas XML.
  • Soluciona problemas de paginación con algunas estructuras de categorías enlace permanente.
  • Añade más campos a ser devueltos por el método wp.getPost XML-RPC.
  • Evita errores al actualizar automáticamente desde versiones muy antiguas de WordPress (pre-3.0).
  • Corrige los problemas con el editor visual cuando se trabaja con subtítulos.

Además: La versión 3.4.2 corrige algunos problemas de seguridad y contiene algunas endurecimiento de seguridad. Estas cuestiones fueron descubiertos y tratados por el equipo de seguridad de WordPress:

  • Fije sin filtrar capacidades de HTML en múltiples sitios.
  • Fijar una escalada de privilegios posible en la variable Protocolo Atom Publishing.
  • Permitir operaciones de plugins de red solamente a través del administrador de red.
  • Endurecimiento: Simplificar mensajes de error cuando la carga falla.
  • Endurecimiento: Validar un parámetro pasado a wp_get_object_terms().